Mails are not sended

Rafael     Mar 21 2:44AM 2018 GUI

Ver. 2.1.0

I've configured the email send always. If I make a test, it works, but when the backup is ended not email is sended. I have two task and it's the same account in both with differents subjects.

A suggestion for new releases is that we can copy and paste the acounts details for a existing task.

Thanks in advance,


gchen    Mar 21 9:26AM 2018

Were there anything in the logs that explained why it failed? If you turn Verbose Logging on then there will be more detailed information.

One reason this can happen is that the full backup log may be too large that it exceeds the limit imposed by your smtp server.


Rafael    Mar 23 5:36AM 2018

Nothing in logs..... simple or verbosing...

At home, the same issue. This is since i upgraded from beta to stable 2.1.0


gchen    Mar 23 1:13PM 2018

The email will only be sent if the job is scheduled. If you start the job manually with the Schedule to run at specific times checkbox disabled, the email will not be sent after the job is finished.


Rafael    Mar 25 4:17AM 2018

I have all the jobs scheduled..... and send email also checked.


Lance    Mar 25 9:07AM 2018

I came across this post in trying to find a solution for what seems to be the same issue.

Test email sends fine, scheduled job doesn't send anything.

Duplicacy Personal 2.1.0 on Windows running as administrator with service enabled.

Verbose logs have nothing:

10:00:37.244    Saved file snapshots/###########/7 to the snapshot cache
10:00:37.315    Uploaded file snapshots/###########/7
10:00:37.315    Backup for C:\Users\########### at revision 7 completed
10:00:37.315    Files: 62792 total, 38,296M bytes; 87 new, 215,424K bytes
10:00:37.315    File chunks: 7722 total, 38,688M bytes; 16 new, 99,574K bytes, 26,373K bytes uploaded
10:00:37.315    Metadata chunks: 7 total, 21,082K bytes; 7 new, 21,082K bytes, 7,157K bytes uploaded
10:00:37.315    All chunks: 7729 total, 38,708M bytes; 23 new, 120,656K bytes, 33,530K bytes uploaded
10:00:37.315    Total running time: 00:00:35
10:00:37.315    12 files were not included due to access errors
10:00:37.315    Deleting the shadow copy used for this backup
10:00:37.407    The shadow copy has been successfully deleted


gchen    Mar 25 7:42PM 2018

This turns out to be a regression bug introduced by one of the late betas. I fixed the bug and redid the 2.1.0 release. If you download the installer again and overwrite the existing installation, it will say build c8a482 in the log window on startup.


Rafael    Mar 27 3:06AM 2018

Thanks¡¡¡

Downloaded and installed and now it's working fine for me.


Lance    Mar 28 7:59PM 2018

Took me awhile to get here, but I had to manually uninstall, delete the registry entries and reinstall for it to suddenly start attempting to send email; however, I've hit a new snag.. here from my verbose logs..

20:52:54.000    CURL: 235 ok, go ahead (#2.0.0)  
20:52:55.000    CURL: MAIL FROM:<########>  
20:52:55.000    CURL: 250 ok  
20:52:55.000    CURL: RCPT TO:<#########>  
20:52:56.000    CURL: 250 ok  
20:52:56.000    CURL: DATA  
20:52:56.000    CURL: 354 go ahead  
20:52:57.000    CURL: From: #######  To: ######  Subject: Duplicacy backup    Log file: C:\Users\####\.duplicacy\logs\backup-log-20180328-205200  2018-03-28 20:52:00.197 INFO STORAGE_SET Storage set to sftp://sftpbackup@192.168.20.10:5000/duplicacy 2018-03-28 20:52:00.198 DEBUG PASSWORD_ENV_VAR Reading the environment variable DUPLICACY_GUI1_SSH_KEY_FILE 2018-03-28 20:52:00.662 DEBUG SSH_PASSWORD Attempting password login 2018-03-28 20:52:00.662 DEBUG PASSWORD_ENV_VAR Reading the environment variab
20:52:57.000    CURL: Local/151314CB-393A-4E28-841C-90D65BB7E4CD.aplzod/ 2018-03-28 20:52:06.250 DEBUG LIST_ENTRIES Listing AppData/Local/ABBYY/ 2018-03-28 20:52:06.251 DEBUG LIST_ENTRIES Listing AppData/Local/ABBYY/FineReader/ 2018-03-28 20:52:06.251 DEBUG LIST_ENTRIES Listing AppData/Local/ABBYY/FineReader/12.00/ 2018-03-28 20:52:06.252 DEBUG LIST_ENTRIES Listing AppData/Local/ABBYY/FineReader/12.00/Bonus.ScreenshotReader/ 2018-03-28 20:52:06.254 DEBUG LIST_ENTRIES Listing AppData/Local/ABBYY/FineReader/12.00/Bonus.Scre
20:52:57.000    CURL: SSL_write() returned SYSCALL, errno = 10053

20:52:58.000    CURL: SSL_write() error: error:1409F07F:SSL routines:SSL3_WRITE_PENDING:bad write retry

20:52:58.000    CURL: Closing connection 0

Thoughts?


gchen    Mar 28 10:16PM 2018

This looks like a line break issue. Currently the email body uses \n. I think the standard calls for \r\n however it seems many SMTP servers do not care.

Lance, I uploaded a new build that uses \r\n as the line breaks. Can you try it? The new build number is 3200c6. You just need to run the new installer to overwrite the existing installation.


Lance    Mar 28 11:55PM 2018

Thank you for such quick responses.

I downloaded and installed the latest and I received the same error, I host my own domain @ polarismail.com with their smtp server being smtps://smtp.emailarray.com.

Here's the log:

00:45:01.000    CURL: RCPT TO:<#####>  
00:45:02.000    CURL: 250 ok  
00:45:02.000    CURL: DATA  
00:45:02.000    CURL: 354 go ahead  
00:45:03.000    CURL: From: #####  To: ####  Subject: Duplicacy backup    Log file: C:\Users\####\.duplicacy\logs\backup-log-20180329-004200  2018-03-29 00:42:00.618 INFO STORAGE_SET Storage set to sftp://sftpbackup@192.168.20.10:5000/duplicacy 2018-03-29 00:42:00.623 DEBUG PASSWORD_ENV_VAR Reading the environment variable DUPLICACY_GUI1_SSH_KEY_FILE 2018-03-29 00:42:13.565 DEBUG SSH_PASSWORD Attempting password login 2018-03-29 00:42:13.565 DEBUG PASSWORD_ENV_VAR Reading the environment variab
00:45:03.000    CURL: C/Acrobat/Cache/Cache/ 2018-03-29 00:42:21.655 DEBUG LIST_ENTRIES Listing AppData/Local/Adobe/AcroCef/DC/Acrobat/Cookie/ 2018-03-29 00:42:21.656 DEBUG LIST_ENTRIES Listing AppData/Local/Adobe/Acrobat/ 2018-03-29 00:42:21.657 DEBUG LIST_ENTRIES Listing AppData/Local/Adobe/Acrobat/DC/ 2018-03-29 00:42:21.658 DEBUG LIST_ENTRIES Listing AppData/Local/Adobe/Acrobat/DC/Cache/ 2018-03-29 00:42:21.659 DEBUG LIST_ENTRIES Listing AppData/Local/Adobe/Acrobat/DC/ToolsSearchCacheRdr/ 2018-03-29 00:42:21.660 DEBUG
00:45:03.000    CURL: SSL_write() returned SYSCALL, errno = 10053

00:45:04.000    CURL: SSL_write() error: error:1409F07F:SSL routines:SSL3_WRITE_PENDING:bad write retry

00:45:04.000    CURL: Closing connection 0

Based on your suggestion it could be a picky SMTP server, I set it up temporarily to gmail and it does work which clearly shows it something to do with my provider.

00:51:00.000    Log file C:\Users\####\.duplicacy\logs\backup-log-20180329-005000 has been emailed to #######

However, I'd prefer to not be forced to use a public email provider and keep my backup status messages private. Any other thoughts?

Thanks Lance


gchen    Mar 29 9:23PM 2018

Lance, it could be just that your SMTP server limits the size of the email it can receive. Maybe if you turn off verbose logging it may work. Or try backing up a test directory to produce a really small log.


Lance    Mar 30 4:18PM 2018

Thanks gchen. I don't think it's a maximum size as the logs were not too huge, for the most part less than 2M uncompressed.. But clearly it's something to do with my mail provider -- I'll submit a support ticket into their system and see if i can get it solved. If I get it solved, I'll report back here.


Copyright © Acrosync LLC 2016-2017