Restore to another folder does not work

Mark    Jan 23 8:17PM 2017 GUI

When I go to restore a file, I click the folder and choose a folder to restore to. I then right-click the file I want to restore and choose restore. However, it always overwrites the original directory.


Mark    Jan 23 8:18PM 2017

Here is the event in the log: 19:16:49.000 Command: duplicacy -background -log restore -r 1 -overwrite -- "Shared Info/IMG_4440.JPG" 19:16:50.412 Storage set to b2://Redeemer-Duplicacy 19:16:55.556 Failed to read the symlink: readlink C:\Users\administrator.DOMAIN\Documents\My Music: Access is denied. 19:16:55.556 Failed to read the symlink: readlink C:\Users\administrator.DOMAIN\Documents\My Pictures: Access is denied. 19:16:55.556 Failed to read the symlink: readlink C:\Users\administrator.DOMAIN\Documents\My Videos: Access is denied. 19:16:55.557 Restoring C:\Users\administrator.DOMAIN\Documents to revision 1 19:16:55.653 Restored C:\Users\administrator.DOMAIN\Documents to revision 1 19:16:55.653 Total running time: 00:00:03

I am trying to restore IMG_4440.JPG to C:\Users\adminsitrator.domain\Documents


gchen    Jan 24 11:43AM 2017

What is the folder you were trying to restore to? Duplicacy sets that directory as the current working directory and then runs the restore command. So if it still restored to the original directory then it means setting the current working directory failed, but if that happens you should have seen an error before that.

Can you check if there is a '.duplicacy' folder under the folder you were trying to restore to?

A workaround that should always work is to use the CLI version which can be found under the same directory as the GUI executable. Run the init command under the restore folder, and then run the restore command. Here is the user manual if you need more information.


Mark    Jan 25 2:46PM 2017

I am trying to restore IMG_4440.JPG to C:\Users\administrator.domain\Documents Yes, there is a .duplicacy folder in that directory.


gchen    Jan 26 6:47PM 2017

I thought Duplicacy was trying to write to the repository instead of the restore directory you specified. So you were using the repository as the restore destination directory. Can you try using a different directory to see if the problem persists?


Log in to comment
Copyright © Acrosync LLC 2016-2017